Zed - Issue with Claude models from Zed.dev – Incident details

All systems operational

Issue with Claude models from Zed.dev

Resolved
Partial outage
Started 20 days agoLasted about 3 hours

Affected

Agent

Partial outage from 11:23 PM to 2:01 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved upstream.

  • Identified
    Identified

    All requests for Claude models with the default profiles are currently failing with "'web_search' is reserved for server tools and cannot be used as a custom tool name"

    This can be worked around by disabling the web_search tool in your current profile, switching to API key access, or using an alternative model family.